服务器问题集锦,包括 Linux(Ubuntu, Centos,Debian等)和Windows Server服务器
正如问题描述,任何人都可以指向一个很好的文档,或者如果可能给我的基本步骤来configuration一个Windows Subversion服务器(1.4.3),请? 我已经有服务器上运行的颠覆,apache和svnserve。 局域网内的现有用户已经在SSPIauthentication上。 我需要让一些新的非域名非NTLM用户访问现有的存储库。 我不想使用svn:// passwdconfiguration,因为这通过networking以明文传输数据和密码。 SSPI不适用于局域网外的这些用户。 所以这也从窗口出来。 我期待看看SSL访问在我们的情况下是否可行。 任何帮助是极大的赞赏。
我有Tomcat的前面的Apache,使用mod_rewrite和mod_proxy中继请求,同时直接提供静态内容。 Tomcat服务器可能会陷入停顿并停止响应,或者只是简单的崩溃。 我的问题是,在这种情况下,它需要与Apache的httpd下来。 甚至在我把Tomcat设置成直线后,它也不会回来。 发生这种情况时,再次运行apache的唯一方法是发出一个停止命令,然后kill -9剩余的apache进程,最近我还必须运行ipcrm来删除信号量,否则我得到一个“设备上没有剩余空间”错误。 我的猜测是,所有的Apache的工人都成为代理线程,等待超时,而没有其他任何服务。 我不想更改ProxyTimeout ,因为在正常的操作过程中,一些请求确实需要很长时间。 但是我想告诉apache停止所有正在等待的代理请求,并重新开始。 有这样的事情,还是有另一种方法,我应该这样做? 我使用的是Ubuntu 8.04。
我正在尝试检测现有的目录,支持在URL中使用和不使用尾部斜杠,但是不对丢失的斜杠进行redirect。 这是规则: RewriteCond /home/user/public_html%{REQUEST_URI} -d RewriteRule ^ /home/user/public_html%{REQUEST_URI} [L] RewriteCond /home/user/public_html%{REQUEST_URI}/ -d RewriteRule ^ /home/user/public_html%{REQUEST_URI}/ [L] 当URL包含结尾斜线时,第一条规则正常工作,但第二条规则不适用于没有尾随斜线(例如/ foobar / works但/ foobar不)。 我怎样才能设置这个没有做30倍的redirect?
我知道这不是一个好问题,但是我目前没有任何可能“自我testing”的性能,因为我没有访问任何专用的服务器,我首先必须购买一台服务器。 您在Apache SSL性能方面的经验(每个Seceond的SSL请求)有哪些? 对于您的某些示例和/或估计,您可能会“开盒即用”,对于最新的硬件(如英特尔酷睿i7-920)上默认安装的带有SSL证书的Apache 2, (4 GHZ的核心)。 (使用SSL请求我的意思是首次请求与所有的SSL握手,然后5“跟进请求”与build立的SSL“连接/握手”)(数据的大小约10KB)。 上面提到的硬件最有可能实现每秒多less次请求。 或者在您的环境中使用有关SSL性能的硬件来达到什么目的)。 (Probelem对SSL性能我没有任何线索,我读了很多,SSL连接更糟糕,我不知道是否可以实现最新的硬件10请求秒或200或2000 (用一个标准的Apache没有SSL几千个请求每秒应该是可能的?) 非常感谢你!! 一月
在IIS 6.0中,我需要创build主机头来承载我们的Web服务器上的多个网站。 我们正在使用networking负载均衡pipe理器有三个服务器的群集Web场。 假设我们使用“服务器组”的内部IP地址,我该如何为内部IP地址设置主机头? 头部是由每个节点机器的内部IP地址还是服务器“组”的IP地址组成的?
我需要在许多机器上安装msi。 我写了一个脚本来检查版本并在必要时进行部署,但似乎并不喜欢msiexec调用。 可以msiexec从有限的用户运行,还是只有pipe理员? 有人能指出我正确的方向吗? 或者,什么是更好的解决scheme?
我刚刚删除了Visual Studio 2010 beta 1,并将Beta 2安装在win 2008 Web Server上。 执行此操作后,我的应用程序池无法启动。 我手动编辑了应用程序池,并select了新的.net 4.0框架。 但是,当我启动应用程序池,并在该池中的应用程序请求一个页面时,我得到一个“HTTP错误503.该服务不可用。 如果我看看IIS中的应用程序池,我可以看到它已经停止。 去事件查看器,我发现这个错误消息:工作进程无法预先加载.Net运行时版本v4.0.20506。 现在 – 我们有这个问题。 Build 20506是beta 1版本。 Beta 2已经构build了21006.所以由于某些原因,尽pipe我更新了应用程序池以使用新安装的.NET框架,但它仍然会尝试加载Beta 1。 那么这个设置存储在哪里,我该如何改变呢?
今天解压缩一个非常大的档案后,我们的一台红帽服务器变得没有反应。 重新启动后,我们收到以下文件系统错误。 Inode 93464太大意外不一致运行fsck手动 立即运行fsck提示我们截断Inode。 这已经产生了一些问题。 喜欢,和Inode怎么变大? 如果你截断所说的Inode会发生什么。 我假设你失去对Inode引用的文件和/或目录的逻辑访问,以及对其他链接的Inode的任何其他引用。 我们正在运行Redhat Enterprise 4。
我的环境是Win server 2003充当服务器场的应用程序服务器。 我需要安装.NET 3.5,以便各种应用程序可以在SharePoint网站上运行。 不幸的是,这不是被certificate是可能的,我看到解决它的唯一行动是删除/重新安装所有的.NET。 我的问题是这是否会以任何方式“伤害”我的SharePoint安装。 我需要它是一个快速和无痛的过程,以便服务器可以以最小的停机时间恢复。 对于任何好奇的人来说,安装程序GUI或EventViewer都不会有任何错误信息,但是VSSWMSIFailInfo.txt还有这个问题: DDSet_Error: CConfigEntry::RefreshConfigFile could not load _spConfigDoc path=C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\WSF30.tmp isSuccessful=0 Error code: 0x1 DDSet_Error: CFxInstaller::SetupExtensions extensionElement.Initialize failed. cswMachineConfigPath=C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\config\WSF30.tmp. Error code: 0x80004005 DDSet_Error: CFxInstaller::SetupBaseComponents SetupExtensions failed. Error code: 0x80004005 DDSet_Error: Setup failed. Error code: 0x80004005 唯一相关的信息,我可以find关于这是MSDN上的这篇文章: http : //social.msdn.microsoft.com/Forums/en-US/netfxsetup/thread/7bc9797b-10ec-42c5-a21e-99c2b45b83ad/ 。 不幸的是,build议的决议不适合我。 因此,我留下了霰弹枪的解决scheme…
在我们更改服务器date之后,通过RDP连接到我们的Microsoft Windows Server 2003 Web和数据库服务器的情况将不可预知地下降。 它通常发生在我们离开服务器date更改并通过RDP隔夜login。 我们只能通过重新启动服务器或将服务器date重置为当前date来恢复RDP连接。 我们将这些服务器用于Web应用程序用户接受目的; 将服务器date转移到未来将模拟Web应用程序中的时间stream逝。 工作人员然后执行Web应用function的用户验收testing。 感谢所有洞察,为什么这可能发生。 我怎么会开始debugging这样的问题呢? 我正在与我们的托pipe服务提供商合作,希望能尽快获得更多的细节。