服务器问题集锦,包括 Linux(Ubuntu, Centos,Debian等)和Windows Server服务器
这与这个问题有些相关: 批量文件到MASS群组的计算机在networking上的名称,检查答复,并parsing主机名 长话短说…我正在进行一个Vista升级项目…我们基本上没有可靠的数据集,指出我们networking上有哪些机器,主要用户是谁,当前正在运行什么操作系统等等。 我们networking环境的相关(?)细节是: DNS是AD集成并使用安全的dyanamic更新。 清理设置为7天。 工作站的DHCP租约设置为8天。 AD服务器是2003 R2 SP2。 我们有Windows 2000,Windows Vista,Windows Server 2003客户端的混合。 理想情况下,我想要的信息是: LoginDateTime(或SCCM轮询时间),用户名,机器名,IP地址,MAC地址,操作系统 所以我希望这能让我准确地看到我们目前正在运行的东西。 一个陷阱是,当机器升级过夜,机器名称从CGYxxxxx更改为NADxxxxx时,第二天早上当我重新运行我的查询时,我希望能够检测networking上存在这台新机器(并且在MAC地址上,我应该能够假设旧的计算机名称现在是“死”)。 有谁知道是否可以使用WMI来获取这些信息,是否可以从Windows 2000客户端中获取,哪些工作站可以运行或不运行SCCM客户端,以及信息的可靠性和最新性。 更新 另请参阅(使用PowerShell): 对机器名称,当前用户名,使用WMIC或PowerShell的操作系统进行脚本编目
我的默认虚拟主机加载mainsite.com NameVirtualHost * <VirtualHost *> DocumentRoot /var/www/ <Directory /> Options FollowSymLinks AllowOverride None </Directory> </VirtualHost> 另一个虚拟主机我添加,所以当我去myothersite.com它将加载 NameVirtualHost * <VirtualHost *> ServerName myothersite.com DocumentRoot /var/www/myothersite.com <Directory /> Options FollowSymLinks AllowOverride None </Directory> </VirtualHost> 我已经添加了一个logging到我的服务器IP为myothersite.com。 我重新启动Apache服务器,但myothersite.com将不会加载。 我找不到服务器。 当重新启动我得到[warn] NameVirtualHost *:0 has no VirtualHosts
我有一个限制性防火墙的系统,将参与UDP多播(发送和接收)。 什么是一组好的规则,使主机的防火墙允许这个? 这是我目前的设置,在Solaris上使用ipf: # Enable UDP multicasting pass out log quick on INTERFACE proto udp from HOSTIP/32 to 224.0.0.0/4 pass in log quick on INTERFACE proto udp from 224.0.0.0/4 to HOSTIP/32 # Enable multicast ping discovery pass in log quick on INTERFACE proto icmp from any to 224.0.0.1/32 # Allow pings out. pass out quick […]
是否有任何命令或方式来查找sqlserver 2005中长时间运行的查询? 如果其他请告诉我 在此先感谢Koteswar饶
在我的客户端Web服务器上,他有这个apache conf文件: rails_passenger_conf Listen *:80 <VirtualHost *:80> # rails public folder DocumentRoot /www/myclientdomain.com/public ServerName myclientdomain.com RailsEnv production </VirtualHost> 我想添加一个子域到服务器进行testing,所以我添加了一个新的configuration文件,Apache会读: my_dev_subdomain.conf Listen *:80 <VirtualHost *:80> DocumentRoot /www/dev.myclientdomain.com ServerName dev.myclientdomain.com </VirtualHost> 并使用apachectl –configtest我得到这个: [warn] _default_ VirtualHost overlap on port 80, the first has precedence (98)Address already in use: make_sock: could not bind to address [::]:80 现在,我显然不是Apache专家。 我只是一个Web开发人员,但我想我已经足够了解Webpipe理,以获得一个基本的子域运行…显然不是。 […]
我遇到了通配符域的问题。 我们使用Windows 2003 Server。 我们在其中一个网站的DNS设置中创build了一个通配符条目。 我们这样做是因为我们需要创build大约20个子域。 我们在IIS中configuration了sub1.mydomain.com,sub2.mydomain.com等子域,每个子域都指向相应的文件夹。 最近我们观察到一个问题。 谷歌已经报道,我们有相当大量的网页(约五十万)。 但实际上,我们没有那么多页面。 我们做了我们的家庭工作,我们已经确定,进入一个不存在(或未定义)的子域名,如asdfsf.mydomain.com正在加载www.mydomain.com的内容。 我们的想法:子域中可能有一个错误的链接,它连接到主域中可用的文件夹。 细节:让我们想象我们有这个文件夹,www.mydomain.com/message-board/。 由于错误的链接,用户将能够访问像这样sub1.mydomain.com/message-board相同的页面。 search引擎将其视为一个不同的页面并对其进行索引,因此页面总数也会增加。 现在的问题是,当用户input一个不存在的子域时,我应该怎样在IIS中加载错误页面呢? 而且,我们的想法是否正确? 请帮忙!
我正在使用SharePoint 2007企业+发布门户模板+ Windows Server 2008.我想利用SharePoint来pipe理工作项目,我想让大师在这里推荐一些像我这样的新手一些很好的教程(更好地通过configuration方式,不通过编码)。 我的要求是, 经理可以将任务分配给工作人员,经理可以编辑任务描述,到期date; 工作人员可以看到分配给他们的任务,并可以更新任务执行状态(可以附加一些文件); 经理可以审查经理分配的所有任务,并由工作人员更新; 最好有一个日历视图与任务。 在此先感谢乔治
我的后台组件正在做MySQL查询。 我需要确保MySQL的高可用性(在Windows上)。 我有一个SAN可用于存储数据库文件。 这就是我的想法。 我将安装2个Windows机器,MySQL指向共享数据库文件。 一个将被激活,另一个被动(MySQL服务停止)。 我基本上需要的是在两台机器之间听取信号,当一台机器倒台时,另一台机器会启动MySQL服务。 这是正确的方法吗? 如果是这样,那里有没有任何产品/开源可以帮助我build立这样的环境? 如果我在这种主动/被动模式下使用两台不同的机器 – 我的客户将如何连接? 他们是否必须根据当前活动的机器更改其连接string(基本上是IP地址/机器名称)。 谢谢
有谁知道是否有任何东西会安装到Ubuntu 9.10,让我连接到运行VMWare服务器1.0.x的远程机器? 我不关心在Ubuntu 9.10本身上运行虚拟机,我只是使用一些东西,让我连接另一个运行VMWare服务器1.0.x的盒子,并查看虚拟机,启动和停止等。 “VMWare服务器控制台”曾经(或者是)做到这一点,但是我不知道他们这个星期叫什么,或者我可以把它安装到9.10。
邮递员通常有一个默认的邮递员@你的域名? 我们最近在我们的新服务器上build立了一个新的Mailman实例,默认情况下它有一个实例,但是它只能从其他网站的mailman @ lists发送垃圾邮件,我不确定它来自哪里。 在Debian Lenny上工作。