服务器问题集锦,包括 Linux(Ubuntu, Centos,Debian等)和Windows Server服务器
由于超出了磁盘空间,我在Media Temple上运行的虚拟服务器当前处于脱机状态。 超出的磁盘空间很可能是由服务器上存储的太多备份引起的。 Plesk已经closures,但是我仍然可以通过SSHlogin,而且我不知道在哪里可以find备份。 Plesk在服务器上以什么格式存储备份? (我怎么知道他们来自何时)。 干杯! 克里斯托弗
在内核2.6.18.8的Fedora Core 9networking服务器上,init不会收获僵尸进程。 如果最终没有为进程expression到无法分配新进程的上限,这将是可承受的。 ps -el | grep 'Z'示例输出 ps -el | grep 'Z' : FS UID PID PPID C PRI NI ADDR SZ WCHAN TTY TIME CMD 5 Z 0 2648 1 0 75 0 – 0 exit ? 00:00:00 sendmail <defunct> 1 Z 51 2656 1 0 75 0 – 0 exit ? […]
我们通常不使用漫游configuration文件,但我们需要testing我们的一些代码,以确保我们的工作。 这导致我们build立漫游configuration文件,然后尝试使用有问题的程序。 除了一台机器之外,我们尝试了这一切,一切都很顺利。 在那台机器上,产品失败了。 我们将失败追溯到两个现象:它不能创build任何COM对象,也不能读取Scripting.Dictionary。 进一步的诊断揭示了最近的原因:HKLM上的限制性ACL针对域用户保护了HKEY_CLASSES_ROOT。 它甚至没有授予读取权限。 碰到这个的那个人做了: secedit /configure /cfg %windir%\repair\secsetup.inf /db secsetup.sdb /verbose net localgroup users accountname /add 一切都变好了 我怀疑有一些域策略需要设置为漫游configuration文件是有用的,导致默认情况下,这个ACL设置更宽容。 当然,那是因为我认为在这个ACL添加到域的时候默认设置这个ACL是正常的。 另一方面,这里的pipe理员发誓,我们没有任何政策可以解释这一点。 恐怕我们被宇宙射线击中了。
我无法使用MAILX命令从我的服务器发送邮件,发现其中一些sendmail.cf没有DS的条目。是否还有其他可以禁用邮件function的东西?
我们最近迁移到64位Windows Server 2008.不幸的是,有一些写得不好的应用程序不释放他们保留在JPG文件上的锁。 这里明显的解决scheme是修复应用程序,我们正在进行。 无论如何,在迁移之前,我们使用了一个名为OpenFilesView的应用程序,在http://www.nirsoft.net/上find 。 所有这个应用程序所做的只是删除其他应用程序文件上的句柄。 但是,正如所料,它不适用于64位版本的操作系统。 有谁知道一个64位的等值? 有没有可能是一个内置的命令或M $的附加function,完成相同的事情?
在我们公司,我们有几个应用程序通过来自各种外部供应商的Java小程序运行。 我们的问题是:app1只能在JRE 1.6.05上运行,而app2需要1.6.16。 有没有一种方法可以指定哪个applet获取哪个JRE,而不是只为所有applet(以及所有用户)select一个JRE? 我不认为我们应该为所有用户授权一个JRE,因为即使我们find一个解决scheme,其中一个供应商也会在某个时候发布一个新的补丁,这个补丁将会重新开始整个周期。
在StackOverflow中继续提出一个问题 – 这更像是一个pipe理问题。 我太早地升级了豹子,这是一个愚蠢的错误。 我以为我甩了我的MySQL文件,但最后的备份大约一个月大。 现在我升级了电脑到雪豹,并试图运行旧的MySQL服务器没有发生。 所以我读了你必须重新安装一个新版本的MySQL,我做了,它运行得很好,启动就好了。 但是 – 它似乎设置了一个新的安装,但由于旧版本无法在此平台上运行 – 我如何转储旧数据? 更新 :用户已经帮助我到达数据文件,并尝试复制那里的文件夹。 我已经做了几个文件夹,这些项目显示了当我启动MySQL,但它有权限错误(13),当我尝试select一个表。 Can't read dir of './compass/' (errno: 13) 任何我尝试不起作用。 希望这里有人能帮忙。 谢谢Rich
我们正在Windows 7上build立一个UltraVNC服务器。这个盒子是由我们拥有的设备的观众控制的。 问题是,每当我们做出改变,检查一些东西,更改密码,检查使用新的显示驱动程序,没有什么坚持。 我们已经在Xp上testing过了,一切正常。 我们正在使用最新的稳定版本,并将服务器作为服务加载。 有没有人跑过这个?
我有一个发布的数据库,一个单独的服务器订阅这个出版物。 我们正在使用事务复制(据我所知) 我需要更改ServerA(发布的数据库)上的列将更改反映在ServerB(订户)还是我需要改变它呢? 我是否需要重新初始化任何东西?
在感恩节的某个时候,我的Netbackup安装决定不再喜欢我的磁带库。 一周前它运行良好,除了将新一周的磁带集移动到NetBackup池中之外,没有我能想到的更改。 (我之前把它们移到了一个未被使用的池中,以便在星期五之前不会被写入。) 现在,当我尝试执行备份时,会立即错误输出,错误代码为96:“EMM状态:没有介质可用,无法分配新介质进行备份,存储单元没有可用”。 如果我试图标签磁带,我马上得到错误98:“错误请求媒体(tpreq)”。 但是,目录备份工作正常。 (虽然这是一个不同的游泳池。) 磁带显示在nbemmcmd -listmedia …的输出中,以及正确的池和其他信息。 我已经尝试将磁带移入临时池并查看是否将磁带拉入到NetBackup池中。 我已经validation了我的策略正在引用NetBackup池。 我曾尝试将策略设置到不同的池,然后将其设置回来。 我试过将磁带和策略移到不同的池中。 我重新启动了Netbackup服务器和磁带库。 没有任何区别。 我不知道下一步该怎么看。 如果有人可以build议我可以查看或启用日志,我会很感激。 它是Windows Server 2003下的Netbackup 6.0MP7。