服务器 Gind.cn
  • Linux
  • Windows
  • Ubuntu
  1. 服务器 Gind.cn
  2. apache 2.2 redirect
  3. 如何让Apache“redirect”停止附加完整的URLpath来redirect目标
Intereting Posts
在kickstart文件中使用dynamic值 无线交换如何工作? Linux内核版本控制:Debian Sid vs Ubuntu Precise 删除名称中带有连字符的UNIX目录 监控和logging网站stream量 php5-fpm与nginx会话没有维护/随机丢弃 无法单击Outlook(+ Exchange)中的发送button获取未知地址 bash脚本在cron中返回“内存不足”,但不在shell中 Apache从两个域返回相同的站点 Azure Linux帐户pipe理 Windows通过本地GPO更新 – 可选更新 当访问PHP文件时,nginx会抛出404错误 在RHEL ec2实例上额外启用ip路由 从现有的EBS卷引导EC2实例 PHP在Apache虚拟主机上不起作用

如何让Apache“redirect”停止附加完整的URLpath来redirect目标

如果我编辑一个网站的.htaccess文件,说oldsite.com,并把这个:

 Redirect permanent / http://newsite.com/page 

它工作正常,如果我冲浪到oldsite.com。 但是,如果我冲浪到oldsite.com/about,它会到http://newsite.com/pageabout

我怎样才能把这个老的网站打到绝对的url上,而不需要把剩下的path放在一边呢?

  • 为什么我的Apache访问日志时间戳有时会倒退?
  • 无法禁用RC4
  • ProxyHTMLURLMap不能在apache2.4中工作
  • Apache / Lighttpd负载平衡
  • 当同名文件存在时,apache mod_rewrite失败

  • 我应该使用哪个networking服务器
  • mod_rewrite – 如果一个头不存在,我怎么会失败一条规则?
  • 使用Subversion服务器的Apache内存泄漏
  • 请问Apache mod_rewrite还会重写被传输的HTML内的链接吗?
  • 限制Apache中的基本身份validation尝试次数
 RedirectMatch permanent ^ http://newsite.com/page 

应该这样做。

  • 多用户的目的是什么?
  • 通过Windows域loginvalidationSVN用户
  • 光油需要多less内存?
  • 哪里是最好的位置,以保持共享开发商的网站文件在Linux的层次结构?
  • 使用mod_rewriteclosures网站
  • Apache在特定文件上没有caching
  • 在fedora上启用Sqlite3 for php
  • Apache SSL安装
  • Apache虚拟主机的名称
  • 如何在Apache中启用HTTP-DAV?

  • © 2017 服务器 Gind.cn
  • Topics
  •        
  • Powered by Server
  • Privacy Policy