服务器 Gind.cn
  • Linux
  • Windows
  • Ubuntu
  1. 服务器 Gind.cn
  2. Apache的2.2
  3. configurationApache根据请求的path将404错误redirect到一个位置
Intereting Posts
设置nameserver – bind 是否有可能通过亚马逊的smtp服务与IAMangular色帐户发送电子邮件? 如何以最less的停机时间移动MySQL数据目录? 使用Windows从USB闪存驱动器中删除MBR 如何在链接激活时在Linux中运行DHCP客户端? 即使我从允许的IP连接,Nginx仍然会抛出403 Zabbix和来自老式设备的时间序列数据 如何使用显示信息打开保存的事件日志文件 Apache嵌套限制部分 更改standalone.xml.tmp的位置 由于权限,无法将war文件从本地目录复制到Google Cloud中的tomcat堆栈的web应用程序 在Linux中挂载nfsnetworking共享时出错 打印预览空白IE8 Dell PowerEdge服务器(R210II和R620)何时会因过热而自动关机? HPdynamic智能arraysB120i ESXi性能问题

configurationApache根据请求的path将404错误redirect到一个位置

现在我在我的httpd.conf文件中有以下内容:

ErrorDocument 404 /index.html 

这工作,但我需要一个额外的规则,也将处理我的debuggingpath。 例如,如果我请求

 http://www.mypage.com/debug/page-that-does-not-exist.html 

我希望它redirect到:

 /debug/index.html 

而不是我的文档根目录中的索引。 什么是最简单的方法来完成这个?

  • 随机redirect到一个.html网站的404
  • 一个服务器上的Apache多个主机 – 不同的端口
  • 设置子域Apache不能正常工作
  • www url创build一个错误,非www作品
  • itk_post_read():setgid():操作不允许

  • 我的服务器正在受到TCP连接的攻击
  • MPM Prefork Apache使用荒谬的内存量
  • 虚拟主机,维护现有的应用程序
  • 整理由vloggerpipe理的旧apache日志
  • 阿帕奇崩溃/ hangup doesnt服务请求
 <Directory /debug> ErrorDocument 404 /debug/index.html </Directory> 
  • Apache2突然给了内部500错误
  • 我怎样才能轻松定制Apache Web服务器的错误页面
  • Apache目录列表修剪文件名
  • 有没有办法使用像RewriteRule … 的外部URL?
  • configurationApache只能在重新启动后识别对htdocs的更改
  • Apache限制连接
  • 如何确定大概的最大请求数量?
  • networking服务器停止接受新的连接
  • 无法启动apache …(98)已经在使用的地址:make_sock:无法绑定到地址0.0.0.0:80
  • apache2.2中的大量访问保护

  • © 2017 服务器 Gind.cn
  • Topics
  •        
  • Powered by Server
  • Privacy Policy