在debian wheezy上安装apache 2.4

我有一个debian,当我尝试安装apache2.4

apt-get update apt-get install apache2 

我有2.2版本,有谁知道如何安装2.4?

    如果你确实需要apache 2.4,我build议你尽可能使用jessie来代替你的机器的发行版,尽可能避免有一个混合的源代码环境,这会让你处于一个不太常用,支持较less的configuration。

    否则,如果有一个特定的原因,使你想使用2.4也许有一个解决方法来更新您的PHP文件或其他,以使其工作在Apache 2.2,并保持喘息。

    但是如果你真的想进入一个混合的源代码环境,可以使用apt-pinning,这将涉及2个步骤:

    • 将jessie的源添加到/etc/apt/sources.list
    • 在/ etc / apt / preferences中添加一个固定首选项

    以下是关于它的更多信息: https : //wiki.debian.org/AptPreferences

    请注意,随着机器更新的发展,您可能会面临新的apt依赖性问题,并且将具有混合依赖关系的apache模块安装到2.2或2.4。 如果这是一个可以接受的并发症为您的需要,你可以继续下去。

    显然有Debian喘息和挤压的Apache 2.4 Backports

    也可以使用jessie的软件包。