服务器 Gind.cn
  • Linux
  • Windows
  • Ubuntu
  1. 服务器 Gind.cn
  2. openssl ssl certificate stunnel x509
  3. DER编码的散列
Intereting Posts
NFS + NIS是Linuxnetworking实现常用login和主目录的现代良好实践吗? 如何过滤命令列的顶部输出? netscreen sn25 vs思科asa5505速度 无法启动SQL Server 2008服务 SQL 2005复制不起作用 在插入时切断UTP电缆 运行pipe理员权限的Apache的危险? 使用LDP恢复已删除的项目 无法连接到端口6000以上的任何东西 IBM Dominoredirect 有没有一种安全的方法来取消在Windowsclosures更新 最低PostFixconfiguration只发送电子邮件? 无法在Linux上设置网卡来build立千兆链路 “SQL引擎”不支持mysql“ rsync – 发送增量文件列表,但文件未在服务器上更新

DER编码的散列

根据stunnel4的手册

该目录中的证书应该命名为XXXXXXXX.0,其中XXXXXXXX是cert的DER编码主体 (最低有效字节顺序为MD5哈希的前4个字节)的哈希值。

我怎么能生产这样的东西?

我试了,失败了:s:

  • openssl ./config共享错误(libcrypto.a)
  • 安装支持SNI的OpenSSL以及之前版本的OpenSSL
  • 从Apache提取Certs
  • 有什么方法可以加速RSA吗?
  • Apache2不要求私人SSL密码的密码
openssl x509 -in cert.crt -inform PEM -out cert.der -outform DER 

然后

 openssl dgst cert.der 

  • 无论SNI设置如何,apache始终服务于第一个命名的虚拟主机
  • HAProxy – ssl客户端的ca链不能被validation
  • 为什么OpenVPN使用“-nodes”选项创build密钥?
  • 使PHP curl使用openssl而不是NSS
  • Openssl,确定即时签名证书?

尝试这个:

 # openssl x509 -in cert.pem -noout -hash c59f9aac 

这会给你OpenSSL希望获得证书目录的散列。

  • Squid:如何启用对SSL自签名证书的validation
  • 在Fedora上curl不接受Cloudflare https
  • stunnel4:禁用安全客户端启动的重新协商
  • 无法将证书导入到Exchange 2013中:私钥丢失(我知道它在那里)
  • 升级apache 2.4后不能上传大文件
  • 如何升级的Apache 2.2.29 openssl – 仍然使用旧的0.9.8版本
  • SSL故障,Apache将无法启动
  • 通过代理从远程网站下载SSL证书
  • 我如何信任自签名证书?
  • 使用OpenSSLvalidationS / MIME签名的消息而不检查证书的用途

  • © 2017 服务器 Gind.cn
  • Topics
  •        
  • Powered by Server
  • Privacy Policy