服务器 Gind.cn
  • Linux
  • Windows
  • Ubuntu
  1. 服务器 Gind.cn
  2. .htaccess apache 2.2
  3. 重写规则.htaccess不工作的PHP文件
Intereting Posts
IBM x3630 M4:(0x2)未更新的进度代码 从Bat文件远程closuresHyper V服务器(UPSclosures) 从属logging修改后,与主DB同步 mod_authnz_ldap没有find对象,但不知道为什么? eAccelerator与两个版本的PHP通过FastCGI 分析服务器的硬盘,因为它已经满了 IKEV2configuration文件IP池 为远程login的用户启动虚拟X服务器 在Web服务器上testing负载 用iptablesredirectstream量到鱿鱼不显示自定义错误页面? Apache2.2 – 无法连接? 最好的RAM用于多个SQL实例? Windows 2003如何处理从DHCP创buildDNSlogging? Windows 7文件夹redirect(GPO) 我应该使用哪个服务器? (300GB的MySQL数据库和狮身人面像)

重写规则.htaccess不工作的PHP文件

经过几次尝试,我发现了这一点

RewriteEngine On RewriteRule .* index.php 

没有工作,但

 RewriteEngine On RewriteRule .* index.html 

正在工作,可能的原因是什么? 我该如何解决?

  • 通过phpparsing器传递一个特定的文件
  • .htaccess的htpassword保护,够安全吗?
  • 从一个域访问文件夹时返回404页,但允许从其他域和IP地址访问
  • 阻止使用.htaccess访问子文件的文件
  • 如何只允许特定的目录使用htaccess?

  • 在MediaTemple上使用ModRewrite指示适当的子域失败
  • 如何预gzip静态JS
  • 将特定的域转发到目录?
  • .htaccess匹配参数URLS
  • 阿帕奇重写与wordpress

尝试(循环免费):

 RewriteEngine On RewriteRule ^.*$ index.php [L] 

尝试

 RewriteEngine On RewriteRule (.*)$ index.php 
  • 强制www时mod_rewriteredirect循环。 在域上
  • 带有OS X用户帐户的Apache身份validation
  • .htaccess问题 – 文档根目录 – 我们在这里需要这个RewriteRule吗?
  • 错误500为.htaccess错误
  • Apache .htaccess 301永久redirect
  • 在子目录中的.htaccess中的RewriteRules在父目录中禁用/破坏.htaccess中的RewriteRules
  • 在Apache中编辑htaccess文件
  • 在Nginx的Htaccess
  • Apache – 仅加载基于远程hsot的某些模块
  • .htaccess mod_rewrite删除.php扩展名,但保留URLpath

  • © 2017 服务器 Gind.cn
  • Topics
  •        
  • Powered by Server
  • Privacy Policy