服务器 Gind.cn
  • Linux
  • Windows
  • Ubuntu
  1. 服务器 Gind.cn
  2. nginx
  3. nginx,追加/生活/每个请求www.a.com
Intereting Posts
如何configurationExtreme Networks Altitude 451用于独立AP使用? Linux添加了错误的默认路由 如何从理论上防止一万个服务器中的硬件故障? 在IIS中,将多个应用程序作为独立网站托pipe还是作为默认站点中的虚拟目录更好? Postfix不会通过别名文件传输到PHP文件 rsync从开发到生产 – 所有权/许可 – PermitRootLogin 你如何部署你的.NET Web应用程序? (请推荐!) MySQL突然不能在Windows Server 2003上工作 Ubuntu运行PostgreSQL ESXi上的链路聚合:访客虚拟机中的一个TCP / IPstream是否可以使用多个链路的带宽? 为什么我的IIS6站点不使用AppPool凭证? Server 2008喜欢重新启动自己 在Nginx上运行一个python脚本 保护公共DNS免受攻击的最佳方式 Apache产生了大量的httpd进程

nginx,追加/生活/每个请求www.a.com

我想追加一个string到每个引用根的请求。

例如)www.a.com – > www.a.com/life/

我写了如下conf,但浏览器说有循环redirect:

if ($host ~ 'www.a.com$') { rewrite ^/(.*)$ http://www.a.com/life/ permanent; } 

如何写这个?

  • NGINX中的长链接会导致redirect
  • 防止PHP包含来自其他站点目录的文件
  • Nginx的重写规则问题,以消除URL的结束
  • mod_rails。 Apache + Nginx。 安装乘客Apache后不启动
  • Rails Noob紧急情况:如何重新启动服务器/应用程序? (Rails,Nginx,Linux)

  • NGINX – 禁止的自定义消息
  • Nginx将某个位置redirect到单独的服务器
  • Nginx / SSL证书 – 所有CLI输出都可以,但是加载https页面不起作用
  • Nginx的具体重写规则查询
  • nginx – 连接build立时间太长

你需要这样做

  if ($host ~ 'www.a.com$') { rewrite ^/$ http://www.a.com/life/ permanent; } 
  • 在Ubuntu上删除从源代码安装的nginx
  • Nginx服务器块不能正常工作? – 已经运行其他的虚拟主机,只是这一个不工作
  • Nginxredirect到(貌似)随机域
  • Bootstrap Linux服务器用于URLredirect
  • nginx + php-fpm + apc …压缩?
  • Nginx无法启动ssl密钥错误
  • NGINX反向代理:是否有可能代理caching只有404(或其他)的HTML状态码?
  • nginx重写竹发票的规则
  • 使用Nginx限制对MVC应用程序的一个控制器的访问
  • 两个nginx文件可以相互影响吗?

  • © 2017 服务器 Gind.cn
  • Topics
  •        
  • Powered by Server
  • Privacy Policy