服务器问题集锦,包括 Linux(Ubuntu, Centos,Debian等)和Windows Server服务器
我有一个由VB编写的第三方开发的应用程序。 这是一个32位应用程序,缺less的DLL是olepro32.dll和ieshims.dll 我从哪里获得这些? 我想直接从微软下载而不是第三方。 使用dependancywalker我设法sorting一些丢失的文件。 把c:\ windows \ syswow64放在path中对olepro32.dll有帮助。 我在系统上find了ieshims.dll的副本,并将其复制到应用程序path中。 现在依赖沃克正在显示: 错误:由于在隐式依赖模块中缺less导出function,所以至less有一个模块具有未parsing的导入。 错误:find具有不同CPUtypes的模块。 警告:由于延迟加载相关模块中缺less导出function,至less有一个模块导入未parsing。 怎么办? 我看到一个长长的模块列表,其中x64以红色列出,x86列出黑色列表 解决了。 这是由数据执行保护引起的。
我有一个SQL Server数据库中有数百个数据表,我正在寻找磁盘使用情况统计信息,因为它涉及到每个单独的表。 有没有一个快速的方法来find这些信息?
出于安全原因,我希望只能从一个DNS别名连接到使用远程桌面的Windows 2008专用Web服务器。 我想使用DNS别名而不是IP地址的原因是我没有从我的ISP的静态IP地址,我有一个dynamic的IP,每当我重新启动DSL调制解调器时更改。 非常感谢您的帮助 …
我试图运行Ubuntu作为客户操作系统使用VMWware 1.0.10与Windows 7旗舰版作为主机操作系统。 我以前用Win XP作为主机操作系统,实际上我使用的是相同的.vmx 我的问题是我不能让Win7或Ubuntu能够通过主机名ping其他。 在Ubuntu上安装Samba和Winbind之后,我可以在WinXP下正常工作,但由于某些原因我无法在Win7下运行它。 我可以通过IP地址进行ping操作,客户端操作系统甚至可以通过Windowsnetworking面板下的主机名显示出来(但当然我不能用它做任何事情),但是使用短主机名进行ping操作是行不通的。 此外,Win7防火墙完全closures。
我们的应用程序支持Solaris Sparc,并且它的某些部分依赖于OpenGL。 我找不到关于Solaris x86的OpenGL支持的官方指南。 任何一个人在Solaris x86(包括将Solaris 10安装到普通的PC,在Solaris 10中支持OpenGL的graphics卡是什么types的)都具有OpenGL支持的相关信息或相关经验。 谢谢!
我在Windows Server 2008 x64上使用SQL Server 2008 Enterprise。 我想在每天的午夜运行日常的工作来完成数据库的备份。 任何参考文件遵循这个主题的新手? 在此先感谢乔治
我在SQL2008中复制了两个数据库。 最近两天来自发布服务器的分发数据库已更改为“可疑模式”,并且复制过程已closures。 我从谷歌读了很多,试图修复,但没有成功。 在我的修复过程中,分发数据库已更改为紧急模式。 任何人都可以请提出任何解决scheme?
我有一个cisco pix 515作为一些Web服务器的防火墙。 我想要做的就是自动将禁止的IPS添加到防火墙,以阻止networking级别的stream量。 目前,我有一个软件挂在networking服务器软件上,监视重复login失败,洪水或任何可疑的活动。 缺less的一块是阻止ip被禁止时的stream量。 我认为最好的解决scheme是dynamic地将ip添加到Web服务器前面的PIX的ACL中。 是否可以通过SNMP或通过任何其他方式来做到这一点? Web服务器都运行UNIX。 谢谢。
我有一个java应用程序,在context.xml中有以下行 <Resource driverClassName="com.mysql.jdbc.Driver" maxActive="100" maxIdle="30" initialSize="10" maxWait="7000" name="jdbc/app" password="pass" type="javax.sql.DataSource" url="jdbc:mysql://dbhost:3306/dbname?autoReconnect=true" username="user" validationQuery="SELECT 1" removeAbandoned="true" removeAbandonedTimeout="30" logAbandoned="true" /> 在MySQL'显示variables'告诉我,max_connections是151。 仍然, use information_schema; select count(*) from processlist where User = 'user'; 从来没有给我看20多个连接。 在tomcat的catalina.out -log我得到 Caused by: org.apache.tomcat.dbcp.dbcp.SQLNestedException: Cannot get a connection, pool exhausted at org.apache.tomcat.dbcp.dbcp.PoolingDataSource.getConnection(PoolingDataSource.java:103) at org.apache.tomcat.dbcp.dbcp.BasicDataSource.getConnection(BasicDataSource.java:540) at org.springframework.jdbc.datasource.DataSourceUtils.doGetConnection(DataSourceUtils.java:113) at org.springframework.jdbc.datasource.DataSourceUtils.getConnection(DataSourceUtils.java:79) 我应该检查什么来发现问题?
最近我们一直在把服务器移到EC2上,最近遇到了一个涉及语言环境的问题。 我们使用脚本从头开始构buildAMI,主要基于简化的RightScale脚本。 不过,我们最近在一个国际项目上工作,发现在脚本安装期间(在命令行中发出语言环境结果为posix),区域设置未被设置。 它似乎没有默认的i18n文件。 但是,检查我本地安装的开发服务器(通过GUI)i18n文件存在。 我需要安装哪些软件包以及在脚本安装期间可以运行哪个程序(命令行)来configuration此程序? 我们正在运行当前版本的CentOS。 (5.4)