服务器问题集锦,包括 Linux(Ubuntu, Centos,Debian等)和Windows Server服务器
我正在build立一个MDS结构swigth,并想知道什么build议的最佳做法是分区? 是单目标单发起者还是单发起者多目标? 我们的SANarrays控制器有8个storgae端口连接到交换matrix,我想知道将这些端口分组为单个组别别的含义是什么。
一个小型局域网(15-20用户)有3-4个互联网连接在DSL /有线/ EVDO调制解调器混合。 所有的互联网连接都连接到一个linux盒子上的一个独特的接口,而这个接口又连接到LAN上的所有设备。 我需要设置代理服务器解决scheme,以便代理将其传出连接绑定到当前可用的任何Internet接口。 可用性需要在半实时检查,我想一个小应用程序,通过该接口ping每个接口的各自的DNS服务器,以确定连接可以正常工作。 什么样的代理解决scheme将允许通过不同的接口进行dynamic路由 – 取决于在任何给定的时间哪一个可用。 如果现有的连接在代理切换到不同的接口时被丢弃,那么可以这样做,但是所需的行为是通过代理build立的每个新连接都应该通过当时正在工作的接口。 作为一个额外的好处,是否有一个解决scheme,允许代理服务器通过所有可用的接口(如果有多个可用的接口)轮询它的传出连接,或者做任何更智能的负载平衡forms。
我有几个独立的Debian Linux(Lenny)系统。 现在,所有的系统都configuration了一个通用的login帐户。 此login帐户具有连接到Windows服务器上的Windows共享的networking卷。 我需要在所有系统上创build一批用户帐户(这一部分我想通了)。 在创build所有用户帐户之后,我需要所有用户帐户都具有与当前通用帐户相同的networking卷映射。 networking卷configuration保存在哪里,我可以在那里复制所有用户帐户的configuration?
我有nginx上传模块处理网站上传,但仍然需要传输文件(每个3-20 MB,比方说)到我们的CDN,而不是委托给后台工作。 什么是最好的方式与龙卷风而不阻止其他请求? 我可以在asynchronouscallback中执行此操作吗?
我试图做一些非常简单的事情:如果用户请求主页http://www.OurSite.com/ ,则停止所有规则并正常提供文件。 如果世界上还有其他东西被请求,那就静静地redirect到一个php脚本。 我正在使用这个: RewriteCond %{REQUEST_URI} !^/$ [NC] RewriteRule .* /000_ROUTE.php [L] 似乎我的情况正在被忽略,主页也正在redirect。 我怎样才能做这个工作?
考虑这个简单的规则来隐藏访客的一个丑陋的URL: RewriteRule ^/CleanPage.html$ /index.php?ugly_parameter=yuck&somevar=12 [L] 这条规则似乎是在日志中产生两套“规则运行”。 首先,它运行所有规则,直到findCleanPage.html匹配。 在这一点上,应该做的,但它做了一些愚蠢的事情:它需要复杂的url,“index.php?ugly_parameter = yuck&somevar = 12”,并开始从开始尝试匹配到另一个规则! 我怎么告诉它“index.php?ugly_parameter = yuck&somevar = 12”是我的“最终答案”,不要浪费时间去试试看看它是否与其他东西相匹配? 我以为这是“L”旗?
我想在Linux中的多个文件夹中的任何types的文件(例如perl,cgi,文本,二进制文件,js和…)中replace文本string。 我该怎么做? 坦克。
我正在使用SQL事务复制与拉订阅复制数据库(托pipe自己的分布数据库)从几个服务器跨越VPN到中央服务器。 我有前2个数据库工作正常,但第三个数据库正在导致我的问题。 我的订阅服务器是SQL 2008,源系统都是SQL 2005.源数据库的大小只有几百兆,包含审计数据,所以通过每秒增加约1kb的新logging来简单地增长。 至于复制监视器,代理日志和事件日志显示一切工作正常 – 除了没有数据显示在我的订阅数据库。 分发代理似乎不想从发布者读取快照(以及因此的初始状态和模式)。 新的交易不适用,虽然他们似乎到达确定,因为复制监视器显示的东西,如“5交易与10个命令已交付”。 我希望(和以前一样)在复制监视器中看到关于数据被BCPed的语句。 快照在共享文件夹上的发布者上。 用户可以查看快照“确定”(\\ repldata),并且快照文件夹正在指向它。 但是分销代理似乎没有试图去读它。 我尝试将快照path更改为不正确的内容,甚至没有发现无法访问的错误。 大量的谷歌search等我发现sp_MSget_repl_commands由发行商的分发数据库上的用户调用。 运行一个分析器我可以看到,它只被要求一个代理ID。 在重新启动后,如预期的那样调用序列号0x0,所以我认为这意味着它会查找快照。 但是,从发布者的angular度来看,我们看到有两个代理的数据 – 快照代理和日志阅读器代理(正在查询)。 所以我想我需要告诉分销代理来获取这两个数据。 但是,如何? 更重要的是 – 为什么? 它在我复制的另外两台服务器上运行良好。 我不是一个SQL新手,但这几乎是我第一次在复制,所以不要害怕指责我失去了明显/愚蠢的东西! 如果需要,我可以获取日志文件(例如,来自分发代理),但是它们似乎没有任何错误 – 只是启动并开始应用日志读取器代理更改。 干杯戴夫
我在这里超出了我的“超级用户”深度,并且会喜欢一些支持。 在工作中,我们有一个Excel工作簿(* .xls格式,大约是Office 2003),它维护我们的“工程师”时间表。 这将处理我们在一年中所做的事情以及它有多less“工作单位”。 就一本工作手册而言,只需要几个= SUM(范围)单元格和一些跨页的链接(12张,每个月一个) 它存储在一个服务器上,一个提供完全访问权限的“pipe理”文件夹和一个具有只读访问权限的“工程师”文件夹。 工作簿本身对于“工程师”是只读的,对于“pipe理”是完全访问的。 我认为这些权限是通过Active Directory控制的。 该工作簿受密码保护,假设允许“pipe理”对其进行编辑,即使他们在以“工程师”身份login的terminal上工作。 这种保护防止“工程师”去某些单元格看公式,因此编辑它们。 工作簿有一个macros保存并在closures10分钟后打开。 这是为了阻止其他“pipe理”被任何一个以编辑权限login的人员locking。 我希望这对某个人来说是有意义的:S 现在,我们有微软的小企业服务器2008年。我们有一个shiny的新的基于Web的login,当我们不在现场,所以我们可以到Exchange Webmail和我们的内部网站(使用Sharepoint 3.0)。 “pipe理”希望能够在变更后自动发布这个时间表(他们不想做任何不同于他们现在正在做的事情),以便使用iPhone“工程师”可以检查,而不是办公室。 目前,我正在TechNet上看一下Office 2007上的“Excel Services”,但我不确定此时是否正在运行正确的花园path。 <编辑> 这似乎表明,我必须有Sharepoint Server 2007,没有提到Sharepoint 3.0 … …“MOSS通过添加核心function以及最终用户Web部件构build在WSS上” – Microsoft Office SharePoint Server(MOSS)的维基百科条目这不是个好消息… “…并使用ASP.NET API,可以编写Web部件来扩展WSS的function。” Windows Sharepoint服务的维基百科条目。 这可以带回我需要的东西吗? 这是好消息吗? 我是否需要开始学习ASP.NET? 这里的这个链接意味着我们需要MOSS来做我想做的事,老板们说我们没有得到它。 SharePoint 2007可以做些什么很酷的事情? 回到绘图板。 </ EDIT> 请有人build议一些“进一步阅读”,以帮助我指向正确的方向或让我回到正确的轨道上。 非常感谢。 我会尽力保持这个最新的我如何得到。
我在尝试在我的Ubuntu服务器上安装rtorrent时出现错误。 ./configure –with-xmlrpc-c 我可以使用上面的命令成功地configuration它,但是当我尝试make我也make install时出现错误 看到错误的细节图片: http : //i50.tinypic.com/11t2wlh.jpg 作为一个精简的我不知道究竟是什么错误。