作为一个例子,说我的域名是example.com,这是IIS 7.5上的ASP.NET网站。 我想要安装phpBB并在example.com/forum上提供。
如果我将phpBB设置为自己的应用程序,在example.com之外,我可以在与ASP.NET应用程序相同的IIS服务器上正常运行,但是当我尝试在example.com中将其作为应用程序安装时站点中,或作为example.com中的虚拟目录,安装程序会在尝试连接到MySQL数据库时挂起。 我从IIS获得HTTP 500错误:
HTTP Error 500.0 - Internal Server Error C:\php\php-cgi.exe - The FastCGI process exceeded configured request timeout
这个错误发生在我试图安装的两个PHP应用程序中。 在这两种情况下,应用程序试图连接到数据库。
我完全不确定如何解决这个问题,或者即使它是可以解决的。 简单的香草PHP页面工作正常(例如<? print phpinfo(); ?>做它应该)。 build议?
你有没有看过phpBB的文件在子目录中运行? 您可能需要更改常量(通常在configuration文件中)以反映Webroot。 90%的我以前设置的开源LAMP应用程序就是这种情况。
从你对这个问题的描述中,我假设PHP已经安装并且在你的服务器上工作,如果在另一个web站点上运行PHP脚本而不是example.com。
好的,这里有两个问题:
这似乎并没有涉及到PHP,而是专门针对PHPBB; 我还build议检查在虚拟目录中运行的文档,并尝试将其设置在另一个网站的VD中,以完全排除与example.com相关的任何内容。
可能是因为phpBB要求你在configuration的某个地方指定适当的webroot; 这是很多LAMP Web应用程序常见的。