服务器 Gind.cn
  • Linux
  • Windows
  • Ubuntu
  1. 服务器 Gind.cn
  2. haproxy
  3. HAproxy请求redirect到多个后端
Intereting Posts
Kerberos – KDC和IIS在同一台机器上 Openshift:使用Spring和embedded式Ldap服务器的SocketException(权限被拒绝) 使用git跟踪linuxconfiguration:如何? SQL服务器碎片locking问题 单人ISV,你推荐什么types的服务器硬件? 中级SMTP服务器(exim)如何处理反向散射? 从MySQL 4升级到Mysql 5 – 同my.cnf – 大量的随机断开连接 2台电脑具有相同的Previous ConfigMgr UUID dhcp / bridge上的dynamicIP接口块启动进程 无法启动木偶 如何在启动ubuntu时自动挂载lvm? Trucrypt或任何HDDencryption解决scheme与旁路? 服务器发送具有不可路由地址的被动回复。 使用服务器地址,而不是IIS 8.5 Nginx忽略客户端的HTTP 1.0请求,并通过HTTP 1.1进行响应 Active Directory 2003本机模式与混合模式

HAproxy请求redirect到多个后端

我想知道是否有可能发送匹配特定ACL的HTTP请求可以redirect到HAProxy中的多个后端。 我想将请求的副本发送到另一个后端。

  • 在HAProxy集群中部署更改的最佳方法
  • HAProxy在多层系统上
  • 当后端失败时,Haproxy粘滞会话不会redirect到不同的服务器
  • haproxy:检查单个标题
  • HAproxy 1.5可信CA

检查teeproxy

您可以使用teeproxy将您的请求转发到多台机器。

https://github.com/chrislusf/teeproxy

更新:

我们从积极的转发和高负载的stream量转移了teeproxy,越来越慢我们发现goreplay是一个被动的http转发器,并且可以转发到多个后端。

https://github.com/buger/goreplay

  • Proxy over Redis,HAProxy或twemproxy?
  • HAProxy – ssl客户端的ca链不能被validation
  • 如何使用CentOS 6中的Icinga / Nagios通过HA代理监控networking服务器节点
  • Corosync / Pacemaker + Haproxy失败操作:权限不足
  • 请求在HAproxy上没有命中端口80
  • 如何通知HAProxy我的服务器正在备份?
  • haproxy中的默认后端
  • 慢速POST上传(Linux内核调优)
  • HAProxy前端的IP添加到标题
  • HA代理没有从“无路由到主机”恢复

  • © 2017 服务器 Gind.cn
  • Topics
  •        
  • Powered by Server
  • Privacy Policy