我有一个在169.254范围内具有静态IP的机器。 。 不能改变。 我需要从另一个networking访问这个。 我的想法是使用路由器,并有广域网端口为192.168。 。 设备和LAN端口是192.168。 。 设备。 我已经尝试configurationLAN地址为169.254.1.1的路由器,但不喜欢这个IP地址。 我还能做些什么来完成这个NAT?
IPv4 169.254.0.0/16范围内的地址是链路本地,不能路由。
请参阅RFC 6890,特殊用途IP地址registry :
+----------------------+----------------+ | Attribute | Value | +----------------------+----------------+ | Address Block | 169.254.0.0/16 | | Name | Link Local | | RFC | [RFC3927] | | Allocation Date | May 2005 | | Termination Date | N/A | | Source | True | | Destination | True | | Forwardable | False | | Global | False | | Reserved-by-Protocol | True | +----------------------+----------------+ Table 5: Link Local
此外,该范围内的地址不能被静态分配,因为如果发现重复,则不能执行重复地址检测和更改寻址。
请参阅RFC 3927 IPv4链路本地地址的dynamicconfiguration :
1.6。 替代使用禁止
请注意,169.254 / 16前缀中的地址不应手动configuration或由DHCP服务器configuration。 手动configuration或DHCPconfiguration可能会导致主机使用169.254 / 16前缀中的地址,而不遵循有关此前缀中地址的重复检测和自动configuration的特殊规则。 虽然DHCP规范[RFC2131]指出DHCP客户端应该用ARP来探测新接收的地址,但这不是必须的。 同样,虽然DHCP规范build议DHCP服务器应该在分配之前使用ICMP Echo请求来探测地址,但这也不是强制性的,即使服务器这样做,IPv4链路本地地址也不可路由,所以DHCP没有直接连接到链路的服务器无法检测到该链路上的主机是否已经在使用所需的IPv4链路本地地址。
希望configuration自己的本地地址(使用手动configuration,DHCP服务器或本文档中未描述的任何其他机制)的pipe理员应该使用现有的私有地址前缀之一[RFC1918],而不是169.254 / 16前缀。
具有固定地址的工业设备可以通过NAT连接诸如AB 1783-NATR的路由器。 1:1 NAT路由的一个要求是公共和私有方必须是完全不同的networking地址。 公共可能是:169.156.1.x,私有可能是192.168.1.x
链接http://ab.rockwellautomation.com/Networks-and-Communications/Network-Address-Translation-Device