服务器 Gind.cn
  • Linux
  • Windows
  • Ubuntu
  1. 服务器 Gind.cn
  2. 胶水logging nginx rsyslog现在 syslog tcp
  3. Nginxlogin到TCP端口上的syslog
Intereting Posts
postgres不能在ubuntu重新启动后启动 警告:/etc/hosts.allow,行xx:主机名/名称不匹配 日志logging在daemontools旋转后不可读 在Apache中设置一个子目录 用于Windows Server 2008的FTP服务器 – Filezilla或IIS? 如何使用mod_rewite使用页面的caching副本(如果可用),否则运行dynamic脚本? 所有的SAS驱动器都可以热插拔吗? 我无法自动安装cifs文件系统 如何让Apache,Ubuntu和PHP7使用HTTP / 2? SELinux:如何启用写入访问Joomlacaching目录? 将纪元时间转换为可读时间窗口 kafka docker – 发送邮件时发生错误 我如何设置我的Linux(CentOS)盒来响应* .centos? CentOS虚拟机无法启动sshd 在Ubuntu 11.10上安装libpq-dev的相关性问题

Nginxlogin到TCP端口上的syslog

我需要将Nginx访问和错误日​​志redirect到远程系统日志服务器。 从http://nginx.org/en/docs/syslog.html我看到我可以这样做:

error_log syslog:server=192.168.1.1; 

不过,我需要redirect到一个特定的TCP(而不是UDP!)端口,我试着:

 error_log syslog:server=192.168.1.1:3000; 

但是没有通过。 如何指定Nginx的端口应该是TCP而不是UDP?

非常感谢!

  • 从nginx访问日志中排除IP
  • 通过Haproxy中的连接进行多less个HTTP事务
  • 事件报告和日志logging
  • 文件更改审计(尤其是web.configs)
  • 什么是IIS7请求跟踪日志上的URL_CHANGED事件?

  • 任何关于发布Apache HTTPd访问日志到CouchDB的build议?
  • apache日志分析工具为多个虚拟主机?
  • 如何生成Windows日志以用于testing目的?
  • 如何解决通过控制台检索到的EC2系统日志的长度限制?
  • 我应该如何过滤我的VMWare日志? 我应该search什么? 我应该排除什么?
  • 发出频率跟踪器
  • Debian上的pptpd不会写任何日志
  • 在x-accel-redirect响应之后使用Nginxcallback(或使用logging到套接字)
  • 为远程备份脚本设置日志logging
  • Apache other_vhosts_access.log和access.log日志文件
  • gzip_ratio不打印在nginx日志中
  • 如何转发Docker容器日志到ELK?
  • 如何将Ansibledebugging消息发送到另一个文件?
  • 命令输出在FreeBSD中的恐慌/重启历史
  • 可以减慢Linux上的日志写入速度(ext3)?

  • © 2017 服务器 Gind.cn
  • Topics
  •        
  • Powered by Server
  • Privacy Policy