我很高兴地在Docker容器中运行systemd,但是,它需要CAP_SYS_ADMIN才能dynamic创build私有的tmp装载。
我试图禁用PrivateTmp,PrivateNetwork和PrivateDevices – 但无济于事,当我启动容器,我看到:
Failed to mount tmpfs at /run: Operation not permitted
然而,在/ usr或/ etc中没有任何地方有PrivateTmp = yes(和其他)的服务。 基于: https ://bugzilla.redhat.com/show_bug.cgi?id = 1033604#c14 – 我认为这些都会导致systemddynamic创build一个挂载 – 但必须有更多。 任何意见赞赏。