Ubuntu 10.04LTS VPS启动时,Mysql服务器无法启动

我做了apt-get更新,并在运行10.04LTS的服务器上安装了几个更新。 但是这已经破坏了MySQL。 它不会在启动时启动。 我试图手动启动它使用以下命令:

$ sudo /etc/init.d/mysql restart Rather than invoking init scripts through /etc/init.d, use the service(8) utility, eg service mysql restart Since the script you are attempting to invoke has been converted to an Upstart job, you may also use the restart(8) utility, eg restart mysql start: Job failed to start $ sudo service mysql start start: Job failed to start $ service mysql start start: Rejected send message, 1 matched rules; type="method_call", sender=":1.5" (uid=1001 pid=1796 comm="start) interface="com.ubuntu.Upstart0_6.Job" member="Start" error name="(unset)" requested_reply=0 destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="init")) $ restart mysql restart: Rejected send message, 1 matched rules; type="method_call", sender=":1.10" (uid=1001 pid=2014 comm="restart) interface="com.ubuntu.Upstart0_6.Job" member="Restart" error name="(unset)" requested_reply=0 destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="init")) 

这里是我的/etc/init/mysql.conf文件的服务 , mysql错误日志 &/ etc/ mysql / my.cnf 。 目前,我已经运行sudo mysqld &只有这样,我的服务器开始接受连接,但它会导致问题,因为它必须在每次重新启动后完成。

请让我知道如何解决这个问题。

看起来你有一个完整的磁盘?

 120507 21:12:06 [ERROR] /usr/sbin/mysqld: Disk is full writing './gaurishs_gslive/wp_redirection_logs.MYD' (Errcode: 122). Waiting for someone to free space... (Expect up to 60 secs delay for server to continue after freeing disk space) 

尽pipe如此,这项服务绝对是开始的。 您的启动可能会失败,因为服务已经在运行。