我一直在尝试在互联网上search解决scheme来解决这个问题。 我是我的组织的新IT人员,我们以前的IT没有logging某些事情。 我明白,这是一个不好的做法,但我现在把所有这些都放在一个文档中,以备将来参考。
话说回来; 最近我在我们的服务器上遇到了一个问题。 我们使用的是HP Proliant DL180 Gen6服务器和ESXi 5.0 …问题是, 我无法启动某些虚拟机,因为它给了我I / O错误。 下面看到的是错误;
原因:0(input/输出错误)。 无法打开它所依赖的磁盘“/ vmfs / volumes / 4e7a4edb-08851e40-0c1e-1cc1de700f23 / EON-GATEWAY(192.168.0.1)/ EON-GATEWAY(192.168.0.1)-000001.vmdk”或其中一个快照磁盘。
可以这么说,我closures了所有的虚拟机,然后重新启动主机,跳到BIOS中观察RAID。 我不知道服务器是什么types的RAID,因为它显示了类似的东西;
SLOT1错误:湾11 – (我记得)
有没有办法让我检查究竟是什么问题。因为,我可以看到受影响的硬盘仍然闪烁绿色LED。 在12湾..湾1显示橙色LED和湾4显示什么都没有。
我很困惑如何得到这个sorting。 如果有人能指导我究竟需要做些什么来完成这个sorting,或者可能会提示如何检查RAID /arrays信息。
下面的图片来自智能arrays控制器…



这是一个video链接到服务器硬盘。 我仍然好奇,现在海湾1闪烁蓝色和琥珀色,而其他海湾蓝色(在上面看到的智能arrays屏幕上)..
这可能是VMware问题或虚拟磁盘上的locking问题。 你能捕捉到完整的错误信息吗? 其他虚拟机没有问题吗?
尽pipe如此,看起来您也有物理存储问题。
以下是DL180 G6上的HP Smart Array P410configuration输出:
physicaldrive 1I:1:1 (port 1I:box 1:bay 1, SAS, 2 TB, OK) physicaldrive 1I:1:2 (port 1I:box 1:bay 2, SAS, 2 TB, OK) physicaldrive 1I:1:3 (port 1I:box 1:bay 3, SAS, 2 TB, OK) physicaldrive 1I:1:4 (port 1I:box 1:bay 4, SAS, 2 TB, OK) physicaldrive 2I:1:5 (port 2I:box 1:bay 5, SAS, 2 TB, OK) physicaldrive 2I:1:6 (port 2I:box 1:bay 6, SAS, 2 TB, OK)
您确定没有错误地将驱动器名称设置为1I:1:1 ,这意味着(port 1I:box 1:bay 1) “SLOT1:托架11” ? 这将解释第一个驱动器托架中的琥珀色/橙色指示灯。
鉴于这台服务器没有很好的logging, 很有可能它也configuration了RAID5( 很可能 )。
F1 ) 如果服务器处于打开状态,则可以从ESXi内查看RAIDconfiguration。 通过导航到: Hardware Status > Sensors > Storage 。
如果您的ESXi是使用特定于HP的VMware映像安装的,则您将在其中看到RAIDconfiguration。
如果在VMware内部没有看到任何内容,则需要在BIOS级别重新引导并查看RAIDconfiguration。
系统启动时,当系统提示您inputSmart Array P410configuration实用程序时,您需要按F8键。
一旦进入,select“查看逻辑驱动器” 。
这将显示RAID健康状态,您可以Enter查看详细信息。 这将确定地告诉你哪些磁盘在数组中是好的/坏的/丢失的。
我可能是错的,但我认为你在这里有两个问题。
是的,您似乎遇到了物理磁盘问题,如果可以避免停机时间,则从HP SPP / ACU映像启动,然后进入ACU,运行诊断程序并根据需要更换部件。
然而,第一个错误表明数据存储是基于IP的,即NFS或iSCSI,而不是本地的SAS / SATA磁盘,比如你真正遇到的问题。 你有其他基于IP的数据存储吗? 如果是这样,我会看看他们在哪里,看看是否被closures或删除。
如果幸运的话,您的前任可能会在机箱上安装esxi服务器的正确HP映像,在这种情况下,您应该能够远程访问HP System Management Homepage:
https:// ipofyourserver:2381
这应该能够告诉你更多关于服务器(也包括arrays)的一般健康状况。
如果不是,则应在P410i控制器完成初始化后重新启动服务器并按F8键。 这将让你进入ORCA(数组选项Romconfiguration)。 select“显示逻辑驱动器”。 这应该给你一个本地逻辑驱动器的列表,并且还会说数组是否健康。 请注意,在HP徽标出现后,您可能必须“按任意键”才能看到P410i初始化消息。
最后一件事:我曾多次看到,服务器内部存储盒的内部工作会出现一些问题,这会使驱动器中的LED指示灯变为静音(closures),或将它们置乱,这样一个健康的驱动器就可以闪烁琥珀色而不是绿色。 只是一个公平的警告,不要采取驱动器活动LED太严重:)
您可能还想考虑在服务器上运行固件升级DVD。 那控制器固件是古老的! 我会敦促你下载固件DVD,一旦你得到RAID 5arrays的形状。 控制器固件的更高版本中有相当多的修复和改进。
从这里下载:
http://h20565.www2.hp.com/portal/site/hpsc/template.PAGE/public/psi/swdDetails/?sp4ts.oid=3884083&spf_p.tpst=swdMain&spf_p.prp_swdMain=wsrp-navigationalState%3Didx%253D%257CswItem %253DMTX_9ed665a89aba447d925937f38b%257CswEnvOID%253D4115%257CitemLocale%253D%257CswLang%253D%257Cmode%253D%257Caction%253DdriverDocument&javax.portlet.begCacheTok = com.vignette.cachetoken&javax.portlet.endCacheTok = com.vignette.cachetoken
你可以把它放在USB驱动器上,然后从它启动,刻录成CD,或者直接通过ilo挂载ISO文件。 请注意,运行DVD也将升级bios,nic和ilo固件。